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Equipment 
 
This experiment uses a Windows computer, the CLEA program The Revolution of the Moons of Jupiter, 
and a scientific  calculator.  (Note that the computer mentioned above may provide such a calculator.) 

 
 

Historical Background 
 
Astronomers cannot directly measure many of the things they study, such as the masses and distances of 
the planets and their moons.  Nevertheless, we can deduce some properties of celestial bodies from their 
motions despite the fact that we cannot directly measure them.  In 1543 Nicolaus Copernicus hypothesized 
that the planets revolve in circular orbits around the sun.  Tycho Brahe (1546-1601) carefully observed the 
locations of the planets and 777 stars over a period of 20 years using a sextant and compass.  These 
observations were used by Johannes Kepler, a student of Brahe’s, to deduce three empirical mathematical 
laws governing the orbit of one object around another.  Kepler’s Third Law is the one that applies to this 
lab.  For a moon orbiting a much more massive parent body, it states the following: 
 
 

M
a
p

3

2=
 

 
  

where  

M is the mass of the parent body in units of the mass of the sun 

a is the length of the semi-major axis in  units of the mean Earth-Sun 
distance, 1 A.U. (astronomical unit).  If the orbit is circular (as we assume 
in this lab), the semi-major axis is equal to the radius of the orbit. 

 
p  is the period  of the orbit in Earth years.  The period is the amount of time required for 
the moon to orbit the parent body once. 

 
 

In 1609, the telescope was invented, allowing the observation of objects not visible to the naked eye.  
Galileo used a telescope to discover that Jupiter had four moons orbiting it and made exhaustive studies of 
this system, which was especially remarkable  because the Jupiter system is a miniature version of the solar 
system. Studying such a system could open a way to understand the motions of the solar system as a whole.  
Indeed, the Jupiter system provided clear evidence that Copernicus’ heliocentric model of the solar system 
was physically possible.  Unfortunately for Galileo, the inquisition took issue with his findings; he was 
tried and forced to recant. 
 

Introduction 
 
We will observe the four moons of Jupiter that Galileo saw through his telescope, known today as the 
Gallilean moons.  They are named Io, Europa, Ganymede and Callisto, in order of distance from Jupiter.  
You can remember the order by the mnemonic “I Eat Green Carrots.”   
 
If you looked at Jupiter through a small telescope, you might see the following: 
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Figure 1 
JUPITER AND MOONS THROUGH A SMALL TELESCOPE 

 
 
The moons appear to be lined up because we are looking edge-on at the orbital plane of the moons of 
Jupiter.  If we watched, as Galileo did, over a succession of clear nights, we would see the moons shuttle 
back and forth, more or less in a line.  While the moons actually move in roughly circular orbits, you can 
only see the perpendicular distance of the moon to the line of sight between Jupiter and Earth.  If you could 
view Jupiter from “above” (see Figure 2), you would see the moons traveling in apparent circles.   
 

 

Figure 2 
 

VIEW FROM ABOVE THE PLANE OF ORBIT 
 

Rapparent shows the apparent distance between the 
moon and Jupiter that would be seen from earth. 

 
As you can see from Figure 3 on the next page, the perpendicular distance of the moon should be a 
sinusoidal curve if you plot it versus time.  By taking enough measurements of the position of a moon, you 
can fit a sine curve to the data and determine the radius of the orbit (the amplitude of the sine curve) and 
the period of the orbit (the period of the sine curve).  Once you know the radius and period of the orbit of 
that moon and convert them into appropriate units, you can determine the mass of Jupiter by using Kepler’s 
Third Law.  You will determine Jupiter’s mass using measurements of each of the four moons; there will be 
errors of measurement associated with each moon, and therefore your Jupiter masses may not be exactly 
the same. 

 

Figure 3 
 

GRAPH OF APPARENT POSITION OF A MOON 
 

The apparent position of a moon varies 
sinusoidally with the changing angle from the 
line of sight, θ , as it orbits Jupiter.  Here the 
apparent position is measured in units of the 
radius of the moon’s orbit, R, and the angle 
measured in degrees. 
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This program simulates the operation of an automatically controlled telescope with a charge-coupled device 
(CCD) camera that provides a video image to a computer screen.  It also allows convenient measurements 
to be made at a computer console, as well as adjustment of the telescope’s magnification.  The computer 
simulation is realistic in all important ways, and using it will give you a good understanding of how 
astronomers collect data and control their telescopes.  Instead of using a telescope and actually observing 
the moons for many days, the computer simulation shows the moons to you as they would appear if you 
were to look through a telescope at the specified time. 
 
 
Overall Strategy 
 
This is the overall plan of action for this laboratory exercise. 
 

• Start up the program and use it to familiarize yourself with the Jupiter system. 
 
• Set up observing sessions. 
 
•     Measure positions of Jupiter’s moons over successive clear nights. 
 
• Plot a graph of  your observations for each moon, using the Revolution of Jupiter’s Moons 

program. 
 
• Using this program to help you, fit a sine curve to each graph. 
 
• Determine the period and semi-major axis for the orbit of each moon from its graph, then convert 

the values to years and AU, respectively. 
 
• Calculate the mass of Jupiter from your observations of each moon, then determine the average 

value for Jupiter’s mass from your individual values. 
 

Before You Start 
 
Now is an ideal time to have a little fun with the program and in the process visualize what you will be 
doing and why.  Start up the Jupiter’s Moons lab; then select Log in . . . from the File menu.  Enter your 
name(s) and table number in the dialogue box that appears and select OK.  Now select File . . . > Run . . . ; 
when the next window pops up, simply select OK to accept the defaults for the Start Date & Time; you 
will be going back to change these after you’ve familiarized yourself with the program and the motions of 
the Jupiter system.  Now the window pictured below appears, showing Jupiter much as it would appear in a 
telescope.  Jupiter appears in the center of the screen, while the small, point-like moons are on either side.  
Sometimes a moon is hidden behind Jupiter and sometimes it appears in front of the planet and is difficult 
to see.  You can display the screen at four levels of magnification by clicking on the 100X, 200X, 300X, 
and 400X buttons.  The screen also displays the date, Universal Time (the time at Greenwich, England), the 
Julian Date (a running count of days used by astronomers; the decimal is an expression of the time), and the 
interval between observations (or animation step interval if Animation is selected). 
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Figure 4 

OBSERVATION SCREEN 
 
 
To do something you can’t do with the real sky, select File > Preferences > Animation, then click on the 
Cont. (Continuous) button on the main screen.  Watch the moons zip back and forth as the time and date 
scroll by.  With this animation, it’s fairly easy to see that what the moons are really doing is circling the 
planet while you view their orbits edge-on.  Toreinforce this, stop the motion by selecting Cont. 
again, select File > Preferences > Top View, and start the motion again (Cont.).  Note 
that under the Preferences menu you can also choose ID Color and avoid confusing the 
four moons. 
 
When you are satisfied that you understand the motions of Jupiter’s moons and why they appear the way 
they do, you are ready to start the lab.  At any time you may select Help in the upper right corner of the 
main screen to view help screens on a wide variety of topics.   
 

Turn off the Animation feature before going on to the next section. 
 

 
Procedure 
 
Data Collection 
 
If you have already logged in as described above, stop the motion of the moons (if you have not already) 
and select Run . . . again.  The Start Date & Time window will appear, and now you will change the 
defaults.  Each table will perform a different set of observing sessions.  The starting dates of observations 
for each table, as well as the interval between observations, will given to you by your instructor.  (A typical 
approach is to observe at twelve-hour intervals until you have successfully observed 18 times.)  Fill in the 
table below first; then enter the information into the program.  It is good scientific practice to keep both 
paper and computer records when possible.  (Note that this time you will be replacing the defaults, which 
are for the current date and time.)   
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Table Number  __________________ 
Year   __________________ 
Month   __________________ 
Day   __________________ 
Time Zone  __________________ 
Number of Observations __________________ 
Interval Between Obs. __________________ 

 
 

In order to measure the position of a moon, move the pointer to the moon and left-click the mouse.  The 
lower right-hand corner of the screen will display the name of the moon (for example, II. Europa), the X 
and Y coordinates of its position in pixels on your screen, and its X coordinate expressed in diameters of 
Jupiter (Jup. Diam.) to the east or west of the planet’s center.  This is the crucial figure for our purposes.  
Note that if the name of the moon does not appear, you may not have clicked exactly on the moon, so try 
again.  To measure each moon’s position accurately, switch to the highest magnification that will keep the 
moon on the screen. 

 
Column 1:  Date 
Column 2:  Universal Time 
Column 3:  Day - number of day (e.g. 1.0, 1.5, 2.0, . . .), including cloudy 

days.   
Columns 4-7:  Record each moon’s position under the column for that moon.  

Be sure to note both distance and direction, for example,  2.75W. 
 

You will also use the computer to record your data for later analysis.  After taking a measurement, select 
Record Measurements . . . and enter the data in the dialog box that appears.  You can go back and add to 
or edit this data later using File > Data > Review . . ., but for  the sake of convenience, you may want to 
enter the data for all four moons before you go on to the next observing session.  To be safe, use File > 
Data > Save . . . to save your data.  Otherwise it will be lost if the program closes.  If the program is closed, 
use Load . . . under the same menu to retrieve the saved file. 
 
 
Data Analysis 

 
You now need to analyze your data.  By plotting position versus time, you will use the data to obtain a 
graph similar to the one below.  (The data shown are for an imaginary moon named CLEA, not one of the 
moons in the laboratory exercise.) 
 

Figure 5 
 

SAMPLE GRAPH FOR MOON CLEA 
 

p = 14 days = 0.0383 years 
a = 3 J.D. = 0.00286 A.U. 
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We know the following:  (1) the orbits of the moons are regular, that is, they do not speed up or slow down 
from one period to the next, and  (2) the radius of each orbit does not change from one period to the next.  
The sine curve  should therefore also be regular.  It should go through all of the points, and not have a 
varying maximum height nor a varying width from peak to peak. 

 
Taking as an example the imaginary Moon CLEA, we can determine the radius and period of the orbit.  
The period is the time it takes for the moon to circle the planet and return to the same point in the orbit.  
Thus the time between two maxima is the period.  The time between crossings at 0 J.D., is equal to half the 
period because this is the time it takes to get from the front of Jupiter to the back of Jupiter, or half way 
around.  For some of your moons, you may not get data from your observations for a full period.  You may 
find the time between crossings at 0 J.D. to be of use to you in determining the period, even though the 
moon has not gone through a complete orbit.  

 
The radius of an orbit is equal to the maximum position eastward or westward, that is, the largest apparent 
distance from the planet. Remember that the orbits of the moon are nearly circular, but since we see the 
orbits edge on, we can only determine the radius when the moon is at its maximum position eastward or 
westward. 
 
When you have completed the specified number of successful observing sessions (typically 18, not 
counting cloudy nights), you are ready to analyze the data as we’ve done for Moon CLEA.   
 
Fortunately, this program will help you create the appropriate sine curve.  Select File > Data > Analyze . . . 
and then choose Callisto IV from the Select menu.  (Start with the more distant, slower moving moons 
because the time interval between observing sessions represents a smaller portion of their orbits, and thus 
their curves are easier to fit.)  When the graph of data points appears, try to find a pattern by eye, and take 
note of any data points that seem to be out of place.  To better see the pattern, select Plot > Plot Type > 
Connect Points.  This will display a jagged, “connect-the-dots” version of your graph.  Click on a point at 
which the line connecting the points crosses from negative to positive.  (If this happens several times, 
choose a point toward the left of the screen.)  A date and a value very close to zero should appear in the box 
marked Cursor Value.  Now select Plot > Fit Sine Curve > Set Initial Parameters and enter the date you 
just found as T-zero.  Go back to the graph and find the next point at which the line passes from negative to 
positive (that is, when the moon has completed one orbit.)  Subtract the earlier date from the later date and 
enter this as Period in the dialog box.  If the line does not cross from negative to positive twice, you could 
use the interval between any two crossings as a good estimate of half the period and then double it.  
Similarly, in the case of a fast moving moon, you could measure the time taken to complete several periods 
and then divide the total time by the number of periods for a more accurate figure. Finally, estimate the 
Amplitude of the sine curve by clicking on the peaks and valleys of your graph and reading the Value in 
the Cursor Position box. The Amplitude is equal to the absolute value (i.e., ignore a – sign) of the highest 
peak or theowest valley of your graph.   
 
When T-Zero, Period, and Amplitude are all entered, click OK.  Now a blue sine curve will appear.  It 
should be a rough fit for all your data points.  If not, you may need to repeat the Set Initial Parameters 
step.  If only one or two points are significantly off the blue line, they may represent inaccurate 
measurements. If your instructor allows, you may remove these from  
 
Now you will begin adjusting the fit with the three scroll bars that have appeared.  First adjust the T-Zero 
point.  As you adjust this value, the entire curve will slide to the left or right.  Try to achieve the best fit for 
the data points closest to the T-zero value you selected above. At this stage, pay no attention to the number 
labeled RMS Residual; just use your eyes. After you’ve adjusted the T-zero value, you may notice that the 
points farther away from your T-zero point no longer fit as well.  Now use the Period scroll bar to stretch 
or shrink the curve and achieve a better fit.  If at any time you cannot scroll far enough to get a good fit, 
select Plot > Reset Scrollbars > Normal Sensitivity to re-center the bars.  Next adjust the Amplitude bar 
to better fit the points near the peaks and valleys.  You may wish to return to the other scroll bars for further 
adjustment, but the goal at this point is a good, though not necessarily perfect, fit.   
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Now it is time to fine tune the curve.  Return to adjusting the T-zero scroll bar, this time observing the 
RMS Residual.  The smaller the value of this number is (note that it’s expressed in scientific notation), the 
better the fit.  Move the scroll bar with the arrows until this number is smallest, that is, when one click in 
either direction would make it larger.  Continue this process with the Period and Amplitude bars.  Because 
the three adjustments affect each other, you should then return to the T-zero bar and repeat the scroll bar 
adjustments until all three yield the lowest RMS Residual.  When you have achieved the lowest value, 
select Plot > Reset Scrollbars > Fine Sensitivity.  Then repeat the adjustments for the three scroll bars at 
this more sensitive level.  These last adjustments should result in a highly accurate sine curve drawn to fit 
the data you gathered.   

 
Write down the Period and Amplitude in the table provided on page X. (Recall that the amplitude is equal 
to the radius, which, since we are assuming the orbit is circular, is equal to the semi-major axis.)  Then 
select Plot > Print Current Display to print the graph.  After the graph has been successfully printed, 
choose a different moon from the Select menu.  As mentioned before, it is a good idea to start with the 
slow-moving Callisto and then move on to Ganymede, Europa, and finally Io.  Hint: you may find it easier 
to fit a curve for the fast-moving Io if you use a short Data Span of 10 days, even if your data covers a 
longer period of time. This setting can be found under the Plot menu. 
 
When you have printed all four graphs and recorded all the appropriate data you may close the CLEA 
Jupiter’s Moons exercise and begin answering the questions on the next page. 

 
Calcutating Jupiter’s Mass 
 
You now have all the information you need to use Kepler’s Third Law to find the mass of Jupiter.  But note 
that values you obtained from the graphs have units of days for p, and J.D. for a.  In order to use Kepler’s 
Third Law, you need to convert the period into years by dividing by the number of days in a year (365), and 
the orbital radius into A.U. by dividing by the number of Jupiter diameters in an A.U. (1050).  Enter your 
converted values in the spaces provided in the data table on page X.  With p and a in the correct units, 
calculate a mass of Jupiter using data from each of the four moons.  If one of the values differs significanly 
from the other three, look for a source of error.  If no error is found, the data may not be adequate for a 
better result, in which case you should leave the data as you found it. 
 

M
a
p

3

2=
 

where MJ the mass of Jupiter in units of the solar mass

a is the radius of the orbit in units of A.U.

p is the period of the orbit in Earth years
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From Callisto M
J
= ____________________

From Ganymede MJ= ____________________

From Europa MJ= ____________________ in units of solar masses

From Io M
J
= ____________________

Average MJ = _______________________________________ solar masses
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Questions and Discussion 
 

1. Express the mass of Jupiter in earth units by dividing it by 3.00 x 10-6, which is the mass of Earth 
in solar mass units. 

 
 
 
 
 
 
 

 
 
 
 
Average  MJ   =___________________________________earth masses 

 
 
 
 
 

 
 
 
 
2. There are moons beyond the orbit of Callisto.  Will they have larger or smaller periods than 

Callisto?  Why? 
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Extra Credit 
 
1. Which do you think would cause the larger error in : a ten percent error in p or a ten percent error 

in a?  Why? 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
2. The orbit of earth’s moon has a period of 27.3 days and a radius (semi-major axis) of 2.56 x 10-3 

A.U. (= 3.84 x 105 km).  What is the mass of Earth?  What are the units?  Show your work. 
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Data Sheet A 
 
Collect 18 lines of data, not counting cloudy nights.  Mark cloudy sessions as in the 
sample below. Remember to enter “E” or “W.” 

(1)
Date

(2)
Time

(3)
Day

(4)
Io

(5)
Europa

(6)
Ganymede

(7)
Calisto

7/24 0.0 1.0 2.95W 2.75W 7.43E 13.15W

7/24 12.0 1.5 CLOUDY- ------------ ----------- -----------
 

 
(1)

Date
(2)

Time
(3)

Day
(4)
Io

(5)
Europa

(6)
Ganymede

(7)
Callisto
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Data Sheet B 

 

Moon Period (days) Period (years) Semi-major Axis
(J.D.)

Semi-major Axis
(A.U.)

IV Callisto

III Ganymede

II Europa

I Io
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