MONTGOMERY COLLEGE

Office of Information Technology — WD&CE InTech' Team
Date: February 8, 2006

MEMORANDUM

To: WDCE InTech Team
From: Ray Kimball, Project Manager, TechLEAP/WebLEAP

Subject: How to tweak Studio 8 Dreamweaver for WDCE classrooms

Step by Step Tweaking Instructions

First screen will look like this.

@ Macromedia Dreamweaver § =& x|

File Edit YWiew Insert Modify Text Commands Site Window Help

nacromedia’

DREAMWEAVER'
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= [ Desktop
y My Computer
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* Take a guick lour of Dreamweaver et the most out of Dresmweaver
= Learn about documentation Tips and tricks, training, special offers and
I rBSOUrCES

more available at macromedia, com

= Find authorized training
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Office of Information Technology — WD&CE InTech' Team
Date: February 8, 2006

First Step: To activate the screen, select File>New>Basic Page Document to

get a new document on the screen/ Hit “Create” to create t I“ﬂ yeocument.

Mew Document ﬂ

izenetal | Templates

Categon: B azic page: Presiew:
Bacpane =T
[wnamic page & HTML kemnplate
Template page i Library item
Other @ ®SLT (Entire page)
12335 Stvle sheets @ RALT (Fragment)
Framesets & AckionScript <Moo preview:
Page Designs (C55) = i
Starter Pages @ Javascripk
Page Designs @ sML
Drezcription: l
HTML docurnent
Document Type [DTD;
|<HTML 1.0 Transitioral |
\4

Help Preferences. .. zet more conkent. .. Create I Zancel |
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Original Screen — Toolbars — Looks like this. We will change the look of this screen by
modifying the Insert Toolbar (Common tab):

& Macromedia Dreamweaver 8 - [Untitled-1 {(XHTML)1 = ﬂ
Eile Edit VYiew Insert Modify Te =, ands Site  Window Help
= = ipcss
Comman ¥ E&‘@'é'@@|'@
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=
EE|
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i w Properties

FormatINone j StylalNone d 55 | B ‘I|

FuntlDefaultant j SizEINnnejl jﬂl

EE|;_|E _=|Target| -

[Page Properties. .. I [ List Tkem. .. ]

i
i W Results Io Log...
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1. Modify the Insert Toolbar (“Common tab”) as follows —
a. Select Drop-down arrow on Common Toolbar
b. Select “Show As Tabs” at bottom of Drop-down menu
c. Toolbar should then look like thi

@ Macrornedia Dreamweaver 8 - [Untitled-1 (XHTML35 == ﬂ

Eile Ediif ¥iew Insert Modify Tex
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2. Add Standard Toolbar (Standard Toolbar is Not Set Up on Dreamweaver’s
Default Image. Surprising, but true....)

a. Select View > Toolbars > Select “Standard”

b. Standard Toolbar contains standard GUI icons: “New Document,”
“Open,” “Save,” “Save All,” “Cut,” “Copy” and “Paste,” and
“Undo/Redo.” See bottom toolbar on the new screenshot below.

c. Toolbars at top will then include Standard Toolbar. Image-will look like
this:

@ Macromedia Dreamweaver 8 - [Untitled-1 {(XHTML}] == ﬂ
File Edit View Insert Modify Text Commands Site Window Help
¢ winsert Common  Layout | Forms | Text | HTML | Application | Flash elements vorites = i ks
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i w Properties
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3. Changes to Preferences — There are a number of changes that have to be made to
the Preferences. We will make all these changes by selecting Edit>Preferences.
We will then show screen shots for each of the changes made

a. When you open Edit>Preferences, the Edit>Preferences Dialog Box will
look like this. We will be making changes in a number of these categories
in the Preferences Dialog Box.

Preferences x|

Cateqary General

gglélisggittrTng Document options: [v Show skart page

Cu:uge Farmat [ Reopen documents on skartup

Zode Hinks

Code Rewriting v “Warn when opening read-only files

EEEYS-TE"SW Update links when moving files: IPrompt 'I
vies

File Compare

File: Types | Editars - : : ) ' .

Faonts Editing options: v show dislog when inserting ohjecks

IHigHErtEg . |v Enable double-byte inline input

nvisible Elements
Layers | Switch to plain paragraph after heading
Layout Mode ™ allow mulkiple consecutive spaces

Mew Document

Preview in Browser ¥ Use <strong= and <em in place of b and <i=

gittet 5 ¥ Use C55 instead of HTML tags

atus Bar

validatar ¥ ‘Warn when placing editable regions within <p= or <hl>-<hé> tags
Mazximum number of history steps: I 50
Spelling dickionary: IEninsh {American) j

K I Cancel Help
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4. b. - Edit>Preferences>General. Select and Activate “Allow Multiple Consecutive

Spaces.”

Preferences x|
Cateqory Genagal
gglélisﬂgigtrTng Dockment options: [v Show skart page
Code Format [ Reopen documents on skartup
EEE:E ::;-Eliiting v “Warn when opening read-only files
EEEYS-EE":EE Update links when moving files: IPrompt 'I
File Compare
File Types | Editors »
Faonts Editing optigns: v show dislog when inserting objecks
?;i';:g:;tiglgements |v Enable double-byte inline input
Layers | Switch to plain paragraph after heading
Layout Made v allow mulkiple consecutive spaces

Mew Document
Preview in Browser

Site [w Use 55 instead of HTML tags

¥ Use <strong> and <em: in place of <b> and <i=

Status Bar
validatar ¥ ‘Warn when placing editable regions within <p= or <hl>-<hé> tags
Mazximum number of history steps: I 50
Spelling dickionary: IEninsh {American) j
K I Cancel Help
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5. Make Sure Preferences>Accessibility looks like this:

x

Cateqary Bccessibility

Zeneral

T Show attributes when inserting:

Code Fprmat ¥ Form obiects

Code Hinks

Code Revriting IV Frames

CopyPaste V¥ Media

335 Skyles -

File: Compare: W Images

File Types | Editors

Foniks

Highlightirg

Inwvisible Elements [™ Keep focus in the panel when opening
Lo e ¥ Offscreen rendeting (need ko disable when using screen readsrs)

Layout Mode
Mew Docunment
Preview in Browser

Site
Skatus Bar
Walidatar
(04 I Cancel Help
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6. Edit>Preferences>Code Rewriting
a. Select & Activate “Fix invalidly nested and unclosed tags”
b. Select & Activate “Remove Extra Closing Tags.”
c. Select & Activate “Warn when fixing or removing tags.”
d. Screen should then look like this:

x

Category Code Rewriting

General

Accessibility ' . T

Code Coloring Rewrite cade: W Fix invalidly nested and unclosed tags
Code Format [ Rename Form items when pasting

Code Hinks

Code Rewriting ¥ Remove extra closing tags

Copy/Paste IV aharn when Fixing or removing tags:

335 Skyles

File Compare Mewer rewrite code: v In files with extensions | .as5 .ast ,asc .asp .ascx .asmy .aspx .cfc .cfm
File Types | Editors

Forts Special characters: W Encode <, >, &, and " in attribute values using &
Highlightirg

Invisible Elements URL encoding: % Do nok encode special characters

Layers

Layaut Made i~ Encode special characters in URLs using 2
Mexw Document " Encode special characters in URLs using %
Prewview in Browser

Site

Skatus Bar

Walidatar

(04 I Cancel Help
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7. Edit>Preferences>Fonts

a. Change Code View: font to Courier 16pt (Largest),

Office of Information Technology — WD&CE InTech' Team

This is good for

teaching purposes using the overhead projection & screen.
Cakegary Fonts
General ) —
Accessibility Font settings: C';-'FI"E :I
Code Calaring Grie
Code Format Hehrew
Code Hints Japanese
Code Rewriting Kﬁrﬁan
CopyPaste $ all<i X
55 Styles ur sd
File Compare Linicode
File Tvpes § Editors Yietnamese
mh Western European
Highlightirg
in\v'isil:ule Elements Propaortional Fant: ITimes e Roman j Size: |12 pt { Mediom )j
avers

Layout Mode

Mew Docunment
Preview in Browser
Sike

Skatus Bar
Yalidator

Fixed font: ICu:uurier Mew

| e |1opt (Smal)

Code wiew; ICDurier Mewy

o]

3] s TSR

Cancel Help
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8. Edit>Preferences>Invisible Elements
a. Select and Activate the following additional checkboxes:
i. Scripts

ii. Comments
iii. Line Breaks
iv. Anchor Points for Layers
v. Anchor Points for Aligned Elements.

b. Dialog Box will then look like this:

x

Cateqary Invisible Elements
General
fccessibility . LI} ¥ Mamed anch
Code Colaring shows <L I Named anchors
Code Format w2 ¥ scripts
Code Hinks )
Code Rewriting ‘*-'-l WV Comments
Copy/Paste %5l ¥ Line breaks
55 Skyles
File Compare ;‘J [ client-Side image maps
E:Li';wes el 23 ¥ Embedded styles
Highlighting & ¥ Hidden Farm fields
visible Elements = o
Lavers 3 W Form delimiter
hiﬁ%totqfrgznt &) B anchor points for layers
Presiew in Browser d W anchor points For aligned elements;
Site
Skatus Bar % [ visual Server Markup Tags (ASP, CFML, ...

Yalidatar I monwisual Server Markup Tags (ASP, CFML, ...)
@ [~ 55 display: none

Show dynamic bext as: I-{Recurdset.Field}- ﬂ

Server-Side includes: W Show contents of included File

K I Cancel Help
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9. Edit>Preferences>New Document
a. Make the following changes if necessary:
i. Default Extension - .html
ii. Default Document Type (DTD) — XHTML 1.0 Transition
iii. Dialog Box should look ljke this:

Preferences

Category Mew Docurment

General
Accessibility
Code Colaring
Code Format
Code Hints
Code Rewriting

335 Skyles

File Compare

File Types | Editors
Fonks

Highlightirg
Inwvisible Elements
Layers

Laiaut Mode

Sike
Skatus Bar
Yalidator

Default document: IHTML j
Default extension: | html

CopyfPaste Default Document Type (DTD): IXHTMLI.EI Transttional =]

Default encoding: IWestern European ﬂ

Preview in Browser nicode Marmalization Eorrn: INu:une j

I /

v Use when opening existing files that don't specify an encading

™ Include Unicode Signature (BOM)

W Show Mew Document dialog box on Control+H

(04 I Cancel Help
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10. Edit>Preferences>Preview in Browser.
a. Add the IBM Home Page Reader (HPR) browser to the list by doing the
following:
i. Hit the Plus Sign for “Add Browser.”
ii. Use the Browse Button
iii. Go to Program Files > IBM > select hpr.exe
iv. Hit Open — (add to list).
v. Do not make this the primary or secondary browser — just an
additional browser. Resulting Dialog Box should look like this:

x

Category Preview in Browser

General
Accessibility : _ _
Code Coloring EIELEEE ll _I Edit... |

Code Format
Code Hints

Code Rewriting II\JEEDEEE;%E;D Fiz

Copy/Paste :

C55 Styles Metscpé 7.1

File Compare

File Types | Editors

Fonks

Highlightirg

Inwvisible Elements

Lavers Defaults: [ Primary browser
Layout Mode
[ew Docunent

[™ Secondary browser

Preview in Browser

Site Options: [~ Preview using kemparary file
Skatus Bar
yalidator Selecting this option will create a temporary copy for preview and

server debugging. To update the document directly please uncheck
this option. Mote that deselecting this option does not apply to
previewing ¥SLT, which always use a temparary file.

(04 I Cancel | Help

11. b. Repeat above process in 10 a. and add Program Files> Mozilla>firefox.exe as
an additional browser. (Screen shot not shown.)
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Edit>Preferences>Status Bar
a. Change Connection Speed: from 28.8 kpbs to 56 kbps. See below,

Preferences x|
Category Skatus Bar
General /
gglélisggigtrTng Window sizes: | width | Height | Description /|
Code Farmat 592
Code Hinks 536 196 (640 x 450, DefAult)
Cade Fewriting A00 300 (640 x 450, Maximized)
Copy/Paste 760 420 (800 x 600,Maximized)
55 Skyles 795 470 (832 x 624, Maximized)
File Compare a55 ] (1024 4768, Maximized)
File: Types | Editars S44 375 e TV
Fants
Highlightirig
Invisible Elements
Lavers

Layout Mode

Mew Document
Preview in Browser
Site

Skatus Bar

Walidator

Connection speed: - | Kilobits per second

K ! Cancel | Help |

After making all these changes in the Preferences Dialog Box, hit &'\ to implement
all changes.
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Return screen to its original view by closing the New Document — X:

& Macromedia Dreamweaver & - [Untitled-4 (XHTML)] =& 5[
File Edit YWiew Insert Modify Text Commands Site Window Help

fwInsert Common  Layout | Forms | Text | HTML | Application | Flash elements | Favoribes E AN
REAEEHER-4-8DE|EB-& ¥ fpplceion
i P Tag Inspector

it w Files

@ Desktop ¥ | Manage Sites

= [ Desktop
g My Computer
‘a My Nebwork Places
-8 FTP&RDS Servers
=23 Deskiop items

Untitled-4

: dcade ﬂSpht |5 Design | Title: | Untitled Document Vﬁ‘.ﬁ B A e- | c v @.|

D ERZRe | xBE|o A
Bt Bt

<body [787 % 369+ [1K] L sec

il

i w Properties

Formet [Hone =] Style [hiore = s | Bz | ik

Font | Defadlt Font = SIZEI '” 'I D H =| Targetl |~

[Page Propetties. .. I [ List Itern... ]

4
H

=

+
n

i
i b Resuls IO Log...
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The final screen should look like this:

& Macromedia Dreamweaver & =& x|

File | Edit Wiew Insert Modify Text Commands Site ‘Window Help

Cammon

E

&

o DREAMWEAVER

Open a Recent ltem Create New Create from Samples J Desktop
My Computer
1= open... @ HTML ) CEE5 Style Sheets My Network Places
@ ColdFusion 2 Framesets AP PEEERT
. Deskhop items
@ PHP 2 Page Designs (C585)
@ ASP VBSeript 2 starter Pages
{3 ASP.NET C# 9 Page Designs
@ JavaScript
&) HML
@ ¥SLT (Entire page)
@ css
san Drearmwe aver Site. . Extend
(3 More @) Dreamweaver Exchange

= Take a quick tour of Dreamweaver Get the most out of Dreamweaver

| = Learn about documentation Tips and tricks, training, special offers and
resources more available at macromedia.com

= Find authorized training
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However, when you open a New Document — File>New>Basic Page>HTML, you should

now see all toolbars, including the Standard Toolbar, like this:

Main Menu | Insert Toolbar in Tabs Mode | Document Toolbar | Standard Toolbar

& Macromedia v :amweaver & - [Untitled-a (XHTML)]
= Site  Wfindow  Help

File Edit Wiew Insert Modify Commands

=& ]

[ i)

grplication | Flash elements | Favorites

dwInsert Common  Layout | Forms | Text | HTML

i » Application

# Tag Inspector

@ Desktop Manage Sites

= [ Desktop

e
<bady >

[787 x 369+ [1K] L sec

i w Properties
Formet [Hone =] Style [hiore ~| s | B|2

Font | Defadlt Font = SIZEI '” 'ID H

[Page Propetties. .. I [ List Itern... ]

i b Resuls

:i My Computer
‘:g My Nebwork Places
-8 FTP&RDS Servers
=23 Deskiop items
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